import Foundation
let pattern = ##"(?:\.?)([\w\-_+#~!$&\'\.]+(?<!\.)@(?<!\.)[\w]+[\w\-\.]*\.[a-zA-Z-]{2,3})(?:[^\w])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VALID EMAILS:
davida@yahoo.com, davida-100@yahoo.com, davida.100@yahoo.com, davida111@davida.com, davida-100@davida.net, davida.100@davida.com.au, davida@1.com, davida@gmail.com.com, davida+100@gmail.com, davida-100@yahoo-test.com valid special char ~@davidalberto.com hey@ucl.ac.uk, "this..one"@gmail.com, h.e.y@gmail.com,
the "." at the start should be ignored .davida@davida.com,
suffix should be ignored davida@gmail.com.1a
prefix should be ignored davida@davida@gmail.com,
INVALID EMAILS:
davida, davida@.com.my, davida123.@gmail.a, davida123@gmail.a, davida123@.com, davida123@.com.com, davida()*@gmail.com, davida@%*.com, davida.@gmail.com,
tld is too long davida@gmail.comnnnnnnnn
INVALID EMAILS - TODO:
adjacent "." should not be valid davida..2002@gmail.com
some images a@bg.png 1x@cover.gif
HIDDEN EMAILS:
somethingatgmail.com
something at gmail.com something AT gmail.com
asdf ( at ) gmail.com yoooo (at) gmail.com
HIDDEN EMAILS - TODO:
this at that dot com
this [at] that [dot] com
-----
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)