# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\.?)([\w\-_+#~!$&\'\.]+(?<!\.)@(?<!\.)[\w]+[\w\-\.]*\.[a-zA-Z-]{2,3})(?:[^\w])"
test_str = ("VALID EMAILS:\n\n"
"davida@yahoo.com, davida-100@yahoo.com, davida.100@yahoo.com, davida111@davida.com, davida-100@davida.net, davida.100@davida.com.au, davida@1.com, davida@gmail.com.com, davida+100@gmail.com, davida-100@yahoo-test.com valid special char ~@davidalberto.com hey@ucl.ac.uk, \"this..one\"@gmail.com, h.e.y@gmail.com, \n\n"
"the \".\" at the start should be ignored .davida@davida.com,\n"
"suffix should be ignored davida@gmail.com.1a\n"
"prefix should be ignored davida@davida@gmail.com,\n\n"
"INVALID EMAILS:\n\n"
"davida, davida@.com.my, davida123.@gmail.a, davida123@gmail.a, davida123@.com, davida123@.com.com, davida()*@gmail.com, davida@%*.com, davida.@gmail.com, \n"
"tld is too long davida@gmail.comnnnnnnnn \n\n"
"INVALID EMAILS - TODO:\n\n"
"adjacent \".\" should not be valid davida..2002@gmail.com\n"
"some images a@bg.png 1x@cover.gif\n\n"
"HIDDEN EMAILS:\n\n"
"somethingatgmail.com \n"
"something at gmail.com something AT gmail.com \n"
"asdf ( at ) gmail.com yoooo (at) gmail.com\n\n"
"HIDDEN EMAILS - TODO:\n\n"
"this at that dot com\n"
"this [at] that [dot] com\n\n\n"
"-----\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.