$re = '/(?:\.?)([\w\-_+#~!$&\'\.]+(?<!\.)@(?<!\.)[\w]+[\w\-\.]*\.[a-zA-Z-]{2,3})(?:[^\w])/m';
$str = 'VALID EMAILS:
davida@yahoo.com, davida-100@yahoo.com, davida.100@yahoo.com, davida111@davida.com, davida-100@davida.net, davida.100@davida.com.au, davida@1.com, davida@gmail.com.com, davida+100@gmail.com, davida-100@yahoo-test.com valid special char ~@davidalberto.com hey@ucl.ac.uk, "this..one"@gmail.com, h.e.y@gmail.com,
the "." at the start should be ignored .davida@davida.com,
suffix should be ignored davida@gmail.com.1a
prefix should be ignored davida@davida@gmail.com,
INVALID EMAILS:
davida, davida@.com.my, davida123.@gmail.a, davida123@gmail.a, davida123@.com, davida123@.com.com, davida()*@gmail.com, davida@%*.com, davida.@gmail.com,
tld is too long davida@gmail.comnnnnnnnn
INVALID EMAILS - TODO:
adjacent "." should not be valid davida..2002@gmail.com
some images a@bg.png 1x@cover.gif
HIDDEN EMAILS:
somethingatgmail.com
something at gmail.com something AT gmail.com
asdf ( at ) gmail.com yoooo (at) gmail.com
HIDDEN EMAILS - TODO:
this at that dot com
this [at] that [dot] com
-----
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);