using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+$)\RAnzahl:\h(\d+)\R?(?:\h+davon\R(?:\h+(\d+)\h(.+$)\R?))?";
string input = @"Installierte Busteilnehmer
Anzahl: 1723
automatische Melder
Anzahl: 1490 davon
43 Thermodiff. Melder
1447 O2T-Melder
nicht automatische Melder
Anzahl: 144
Koppler
Anzahl: 45 davon
15 Funkkoppler (81 Funksockel)
Signalgeber
Anzahl: 857 davon
8 Sprachalarmierung
793 Sprachalarmierung integriert im Melder
36 optisch/Sprache
20 optisch/Sprache integriert im Melder";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}