re = /(.+$)\RAnzahl:\h(\d+)\R?(?:\h+davon\R(?:\h+(\d+)\h(.+$)\R?))?/m
str = 'Installierte Busteilnehmer
Anzahl: 1723
automatische Melder
Anzahl: 1490 davon
43 Thermodiff. Melder
1447 O2T-Melder
nicht automatische Melder
Anzahl: 144
Koppler
Anzahl: 45 davon
15 Funkkoppler (81 Funksockel)
Signalgeber
Anzahl: 857 davon
8 Sprachalarmierung
793 Sprachalarmierung integriert im Melder
36 optisch/Sprache
20 optisch/Sprache integriert im Melder'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end