import re
regex = re.compile(r"(.+$)\RAnzahl:\h(\d+)\R?(?:\h+davon\R(?:\h+(\d+)\h(.+$)\R?))?", flags=re.MULTILINE)
test_str = ("Installierte Busteilnehmer\n"
"Anzahl: 1723\n"
"automatische Melder\n"
"Anzahl: 1490 davon\n"
" 43 Thermodiff. Melder\n"
" 1447 O2T-Melder\n"
"nicht automatische Melder\n"
"Anzahl: 144\n"
"Koppler\n"
"Anzahl: 45 davon\n"
" 15 Funkkoppler (81 Funksockel)\n"
"Signalgeber\n"
"Anzahl: 857 davon\n"
" 8 Sprachalarmierung\n"
" 793 Sprachalarmierung integriert im Melder\n"
" 36 optisch/Sprache\n"
" 20 optisch/Sprache integriert im Melder")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")