#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)url\((?:['"]?(?:https?|data):[^'"\)]+['"]?|['"]?([^'")]+)['"]?)\)"
Local $sString = "1. background: url(https://images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"2. background: url(http://images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"1. background: url('https://images/magnifier-ico.svg') no-repeat left center;" & @CRLF & _
"2. background: url("http://images/magnifier-ico.svg") no-repeat left center;" & @CRLF & _
"background: url('images/magnifier-ico.png') no-repeat left center;" & @CRLF & _
"background: url("/images/magnifier-ico.svg") no-repeat left center;" & @CRLF & _
"background: url(./images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"background: url(../images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"background: url(../images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"background: url(../images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"background: url(../images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"background: url(../images/magnifier-ico.svg) no-repeat left center;" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")