import re
regex = re.compile(r"url\((?:['\"]?(?:https?|data):[^'\"\)]+['\"]?|['\"]?([^'\")]+)['\"]?)\)", flags=re.MULTILINE)
test_str = ("1. background: url(https://images/magnifier-ico.svg) no-repeat left center;\n"
"2. background: url(http://images/magnifier-ico.svg) no-repeat left center;\n"
"1. background: url('https://images/magnifier-ico.svg') no-repeat left center;\n"
"2. background: url(\"http://images/magnifier-ico.svg\") no-repeat left center;\n"
"background: url('images/magnifier-ico.png') no-repeat left center;\n"
"background: url(\"/images/magnifier-ico.svg\") no-repeat left center;\n"
"background: url(./images/magnifier-ico.svg) no-repeat left center;\n"
"background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
"background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
"background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
"background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
"background: url(../images/magnifier-ico.svg) no-repeat left center;\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")