use strict;
my $str = '1. background: url(https://images/magnifier-ico.svg) no-repeat left center;
2. background: url(http://images/magnifier-ico.svg) no-repeat left center;
1. background: url(\'https://images/magnifier-ico.svg\') no-repeat left center;
2. background: url("http://images/magnifier-ico.svg") no-repeat left center;
background: url(\'images/magnifier-ico.png\') no-repeat left center;
background: url("/images/magnifier-ico.svg") no-repeat left center;
background: url(./images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
';
my $regex = qr`url\((?:['"]?(?:https?|data):[^'"\)]+['"]?|['"]?([^'")]+)['"]?)\)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}