package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)url\((?:['"]?(?:https?|data):[^'"\)]+['"]?|['"]?([^'")]+)['"]?)\)`)
var str = `1. background: url(https://images/magnifier-ico.svg) no-repeat left center;
2. background: url(http://images/magnifier-ico.svg) no-repeat left center;
1. background: url('https://images/magnifier-ico.svg') no-repeat left center;
2. background: url("http://images/magnifier-ico.svg") no-repeat left center;
background: url('images/magnifier-ico.png') no-repeat left center;
background: url("/images/magnifier-ico.svg") no-repeat left center;
background: url(./images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}