package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*PN: (.+)BN:\s*([0-9]{7}).*`)
var str = `colder.com/AQGdataPN: AQG17006HTBN: 85065002023/06/22
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}