re = /.*PN: (.+)BN:\s*([0-9]{7}).*/m
str = 'colder.com/AQGdataPN: AQG17006HTBN: 85065002023/06/22
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end