$re = '/.*PN: (.+)BN:\s*([0-9]{7}).*/m';
$str = 'colder.com/AQGdataPN: AQG17006HTBN: 85065002023/06/22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);