#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b\w)|(\d+)"
Local $sString = "Freestyle steel" & @CRLF & _
"Freestyle Alloy" & @CRLF & _
"Trekking steel uk" & @CRLF & _
"Single speed" & @CRLF & _
"5 speed" & @CRLF & _
"15 speed" & @CRLF & _
"3 Speed internal gear with 55 coaster" & @CRLF & _
"MTB steel" & @CRLF & _
"Junior MTB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")