re = /(\b\w)|(\d+)/m
str = 'Freestyle steel
Freestyle Alloy
Trekking steel uk
Single speed
5 speed
15 speed
3 Speed internal gear with 55 coaster
MTB steel
Junior MTB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end