using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w)|(\d+)";
string input = @"Freestyle steel
Freestyle Alloy
Trekking steel uk
Single speed
5 speed
15 speed
3 Speed internal gear with 55 coaster
MTB steel
Junior MTB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}