package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b\w)|(\d+)`)
var str = `Freestyle steel
Freestyle Alloy
Trekking steel uk
Single speed
5 speed
15 speed
3 Speed internal gear with 55 coaster
MTB steel
Junior MTB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}