re = /(\d\d\:\d\d)|\:/m
str = 'TEST:ABCDEGF:18:32:aa:12'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result