using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(?\s*(:age == .*?)\)";
string input = @"""Select Where(:sex == \!""F\!"" & :age == 15)""
""Select Where(:sex == \!""F\!"" & (:age == 14 | :age == 15))""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}