// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(?\s*(:age == .*?)\)").unwrap();
let string = "\"Select Where(:sex == \\!\"F\\!\" & :age == 15)\"
\"Select Where(:sex == \\!\"F\\!\" & (:age == 14 | :age == 15))\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}