$re = '/\(?\s*(:age == .*?)\)/m';
$str = '"Select Where(:sex == \\!"F\\!" & :age == 15)"
"Select Where(:sex == \\!"F\\!" & (:age == 14 | :age == 15))"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);