package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(?\s*(:age == .*?)\)`)
var str = `"Select Where(:sex == \!"F\!" & :age == 15)"
"Select Where(:sex == \!"F\!" & (:age == 14 | :age == 15))"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}