package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\\(\w+(?:\.\w+)*?)\.exe[^\\\r\n]*$`)
var str = `C:\Temp\Logs\MyMainApp.SubApp.App.exe.010519.201123.9320.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}