re = /^.*\\(\w+(?:\.\w+)*?)\.exe[^\\\r\n]*$/m
str = 'C:\\Temp\\Logs\\MyMainApp.SubApp.App.exe.010519.201123.9320.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end