$re = '`^.*\\\\(\w+(?:\.\w+)*?)\.exe[^\\\\\r\n]*$`m';
$str = 'C:\\Temp\\Logs\\MyMainApp.SubApp.App.exe.010519.201123.9320.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);