// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\\(\w+(?:\.\w+)*?)\.exe[^\\\r\n]*$").unwrap();
let string = "C:\\Temp\\Logs\\MyMainApp.SubApp.App.exe.010519.201123.9320.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}