#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?|(?'a'.*)\k'a'(\1))\1"
Local $sString = "The quick brown fox jumps over the lazy lazy lazy dog." & @CRLF & _
"The quick brown fox jumps over the lazy lazy dog." & @CRLF & _
"Attack Attack Attack Attack Attack Attack" & @CRLF & _
"Attack Attack " & @CRLF & _
"Attack!!!!!!" & @CRLF & _
"Attack!!" & @CRLF & _
"WAAAAAAGGGGGGHHHHHH!!!" & @CRLF & _
"WAAGGHH!!" & @CRLF & _
"Attack Whatever Attack Attack" & @CRLF & _
"Attack Whatever Attack Attack" & @CRLF & _
"This This This Friend Friend Friend" & @CRLF & _
"This This Friend Friend"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)