const regex = /(?|(?'a'.*)\k'a'(\1))\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(?\'a\'.*)\\k\'a\'(\\1))\\1', 'gm')
const str = `The quick brown fox jumps over the lazy lazy lazy dog.
The quick brown fox jumps over the lazy lazy dog.
Attack Attack Attack Attack Attack Attack
Attack Attack
Attack!!!!!!
Attack!!
WAAAAAAGGGGGGHHHHHH!!!
WAAGGHH!!
Attack Whatever Attack Attack
Attack Whatever Attack Attack
This This This Friend Friend Friend
This This Friend Friend`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);