# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?|(?'a'.*)\k'a'(\1))\1"
test_str = ("The quick brown fox jumps over the lazy lazy lazy dog.\n"
"The quick brown fox jumps over the lazy lazy dog.\n"
"Attack Attack Attack Attack Attack Attack\n"
"Attack Attack \n"
"Attack!!!!!!\n"
"Attack!!\n"
"WAAAAAAGGGGGGHHHHHH!!!\n"
"WAAGGHH!!\n"
"Attack Whatever Attack Attack\n"
"Attack Whatever Attack Attack\n"
"This This This Friend Friend Friend\n"
"This This Friend Friend")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.