$re = '/(?|(?\'a\'.*)\k\'a\'(\1))\1/m';
$str = 'The quick brown fox jumps over the lazy lazy lazy dog.
The quick brown fox jumps over the lazy lazy dog.
Attack Attack Attack Attack Attack Attack
Attack Attack
Attack!!!!!!
Attack!!
WAAAAAAGGGGGGHHHHHH!!!
WAAGGHH!!
Attack Whatever Attack Attack
Attack Whatever Attack Attack
This This This Friend Friend Friend
This This Friend Friend';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;