import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(.*)\\s*Disk.*";
final String string = " Sharename Type Comment\n"
+ " --------- ---- -------\n"
+ " ADMIN$ Disk Remote Admin\n"
+ " C$ Disk Default share\n"
+ " CertEnroll Disk Active Directory Certificate Services share\n"
+ " Department Shares Disk \n"
+ " IPC$ IPC Remote IPC\n"
+ " NETLOGON Disk Logon server share \n"
+ " Operations Disk \n"
+ " SYSVOL Disk Logon server share \n"
+ "Reconnecting with SMB1 for workgroup listing.\n"
+ "Connection to 10.10.10.103 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)\n"
+ "Failed to connect with SMB1 -- no workgroup available\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}