package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?) - (.*?)(?: - (.*?))?(?: - (.*?))?$`)
var str = `2020 02 15 - Joe Sephine
2020 02 18 - Candy Kane - Toot Suites - 123 Some Street
2020 02 19 - Badonk Edonk - On A Boat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}