const regex = /^(.*?) - (.*?)(?: - (.*?))?(?: - (.*?))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?) - (.*?)(?: - (.*?))?(?: - (.*?))?$', 'gm')
const str = `2020 02 15 - Joe Sephine
2020 02 18 - Candy Kane - Toot Suites - 123 Some Street
2020 02 19 - Badonk Edonk - On A Boat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}