re = /^(.*?) - (.*?)(?: - (.*?))?(?: - (.*?))?$/m
str = '2020 02 15 - Joe Sephine
2020 02 18 - Candy Kane - Toot Suites - 123 Some Street
2020 02 19 - Badonk Edonk - On A Boat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end