$re = '/^(.*?) - (.*?)(?: - (.*?))?(?: - (.*?))?$/m';
$str = '2020 02 15 - Joe Sephine
2020 02 18 - Candy Kane - Toot Suites - 123 Some Street
2020 02 19 - Badonk Edonk - On A Boat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);