package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#{(\S+?)\:?[^:]*[o]*[^:]*}`)
var str = `#{fastighet.ägare:2.andel.nämnare:o} #{fastighet.ägare:2.andel.nämnare:o}
#{fastighet.ägare:5.andel.nämnare:o}
#{fastighet.ägare:81.andel.nämnare:o}#{fastighet.ägare:81.andel.nämnare}
#{fastighet.beteckning}#{fastighet.beteckning:o}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}