import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\{(\\S+?)\\:?[^:]*[o]*[^:]*\\}";
final String string = "#{fastighet.ägare:2.andel.nämnare:o} #{fastighet.ägare:2.andel.nämnare:o}\n"
+ "#{fastighet.ägare:5.andel.nämnare:o}\n"
+ "#{fastighet.ägare:81.andel.nämnare:o}#{fastighet.ägare:81.andel.nämnare}\n"
+ "#{fastighet.beteckning}#{fastighet.beteckning:o}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}