$re = '/#{(\S+?)\:?[^:]*[o]*[^:]*}/m';
$str = '#{fastighet.ägare:2.andel.nämnare:o} #{fastighet.ägare:2.andel.nämnare:o}
#{fastighet.ägare:5.andel.nämnare:o}
#{fastighet.ägare:81.andel.nämnare:o}#{fastighet.ägare:81.andel.nämnare}
#{fastighet.beteckning}#{fastighet.beteckning:o}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);