// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)#{(\S+?)\:?[^:]*[o]*[^:]*}").unwrap();
let string = "#{fastighet.ägare:2.andel.nämnare:o} #{fastighet.ägare:2.andel.nämnare:o}
#{fastighet.ägare:5.andel.nämnare:o}
#{fastighet.ägare:81.andel.nämnare:o}#{fastighet.ägare:81.andel.nämnare}
#{fastighet.beteckning}#{fastighet.beteckning:o}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}