import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "</h1>\\s*(<div>)?(.*?)\\s*(</div>)?</header>";
final String string = "<header><h1>A Suspenseful Movie Title</h1><div>The narrative traces the journey of three youngsters from a seaside community who inadvertently capture a homicide on camera. As they unwittingly become enmeshed with the perpetrator, it unravels a convoluted case that entangles numerous families, culminating in an unpredictable outcome.</div></header>\n\n"
+ "<header>\n"
+ "<h1>Movie Title</h1>\n"
+ "A group of extraordinary individuals, each with unconventional occupations, emerged as champions for the common people on the streets by pursuing justice. Suddenly, they gained access to supernatural abilities.\n"
+ "</header>\n\n"
+ "<header>\n"
+ " <h1>Funny Comedy Movie Title</h1>The following is a comical tale of a husband and wife's pursuit of their ambition to obtain a flat.</header>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}