$re = '~</h1>\s*(<div>)?(.*?)\s*(</div>)?</header>~m';
$str = '<header><h1>A Suspenseful Movie Title</h1><div>The narrative traces the journey of three youngsters from a seaside community who inadvertently capture a homicide on camera. As they unwittingly become enmeshed with the perpetrator, it unravels a convoluted case that entangles numerous families, culminating in an unpredictable outcome.</div></header>
<header>
<h1>Movie Title</h1>
A group of extraordinary individuals, each with unconventional occupations, emerged as champions for the common people on the streets by pursuing justice. Suddenly, they gained access to supernatural abilities.
</header>
<header>
<h1>Funny Comedy Movie Title</h1>The following is a comical tale of a husband and wife\'s pursuit of their ambition to obtain a flat.</header>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);