use strict;
my $str = '<header><h1>A Suspenseful Movie Title</h1><div>The narrative traces the journey of three youngsters from a seaside community who inadvertently capture a homicide on camera. As they unwittingly become enmeshed with the perpetrator, it unravels a convoluted case that entangles numerous families, culminating in an unpredictable outcome.</div></header>
<header>
<h1>Movie Title</h1>
A group of extraordinary individuals, each with unconventional occupations, emerged as champions for the common people on the streets by pursuing justice. Suddenly, they gained access to supernatural abilities.
</header>
<header>
<h1>Funny Comedy Movie Title</h1>The following is a comical tale of a husband and wife\'s pursuit of their ambition to obtain a flat.</header>';
my $regex = qr~</h1>\s*(<div>)?(.*?)\s*(</div>)?</header>~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}