# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"</h1>\s*(<div>)?(.*?)\s*(</div>)?</header>"
test_str = ("<header><h1>A Suspenseful Movie Title</h1><div>The narrative traces the journey of three youngsters from a seaside community who inadvertently capture a homicide on camera. As they unwittingly become enmeshed with the perpetrator, it unravels a convoluted case that entangles numerous families, culminating in an unpredictable outcome.</div></header>\n\n"
"<header>\n"
"<h1>Movie Title</h1>\n"
"A group of extraordinary individuals, each with unconventional occupations, emerged as champions for the common people on the streets by pursuing justice. Suddenly, they gained access to supernatural abilities.\n"
"</header>\n\n"
"<header>\n"
" <h1>Funny Comedy Movie Title</h1>The following is a comical tale of a husband and wife's pursuit of their ambition to obtain a flat.</header>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.