import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+) [^<>]*\\bclass\\s*=\\s*\"[^\"]*\\bmd\\b[^\"]*\"[^<>]*>[^<>]+<\\/\\1>";
final String string = "<b sdsd md sdsdds>a</b> \n"
+ "<b>adsa</b>\n"
+ "<b md>a</b>\n"
+ "<b md>sdasdas</b>\n"
+ "<b md class =\"sd\">aaa</b> <b md>aaa</b> <b md>a</b>\n"
+ "<b ac md>a</b>**DENEME** **DENEME**\n\n"
+ "<b md>sd <b md>sd</b></b>\n\n"
+ "<b md>(boş olmasın)</b>\n"
+ "<b md class =\"md\" id=\"1\">aaa</b> <b md>aaa</b> <b md>a</b>\n"
+ "<b md class =\"test sd md test\">aaa</b> <b md>aaa</b> <b md>a</b>\n\n"
+ "<b class=\"...blah md blah...\">(expression)</b>\n\n"
+ "<b class=\"... md ...\"></b> not match because tag is empty\n"
+ "<i class=\"...\"></i> not match because class attribute not include md\n"
+ "<span class=\"...md...\">ANYTHING</span> match\n"
+ "<b class=\"... md ...\"> </b>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}