$re = '/<(\w+) [^<>]*\bclass\s*=\s*"[^"]*\bmd\b[^"]*"[^<>]*>[^<>]+<\/\1>/mU';
$str = '<b sdsd md sdsdds>a</b>
<b>adsa</b>
<b md>a</b>
<b md>sdasdas</b>
<b md class ="sd">aaa</b> <b md>aaa</b> <b md>a</b>
<b ac md>a</b>**DENEME** **DENEME**
<b md>sd <b md>sd</b></b>
<b md>(boş olmasın)</b>
<b md class ="md" id="1">aaa</b> <b md>aaa</b> <b md>a</b>
<b md class ="test sd md test">aaa</b> <b md>aaa</b> <b md>a</b>
<b class="...blah md blah...">(expression)</b>
<b class="... md ..."></b> not match because tag is empty
<i class="..."></i> not match because class attribute not include md
<span class="...md...">ANYTHING</span> match
<b class="... md ..."> </b>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);