const regex = /<(\w+) [^<>]*\bclass\s*=\s*"[^"]*\bmd\b[^"]*"[^<>]*>[^<>]+<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+) [^<>]*\\bclass\\s*=\\s*"[^"]*\\bmd\\b[^"]*"[^<>]*>[^<>]+<\\\/\\1>', 'gm')
const str = `<b sdsd md sdsdds>a</b>
<b>adsa</b>
<b md>a</b>
<b md>sdasdas</b>
<b md class ="sd">aaa</b> <b md>aaa</b> <b md>a</b>
<b ac md>a</b>**DENEME** **DENEME**
<b md>sd <b md>sd</b></b>
<b md>(boş olmasın)</b>
<b md class ="md" id="1">aaa</b> <b md>aaa</b> <b md>a</b>
<b md class ="test sd md test">aaa</b> <b md>aaa</b> <b md>a</b>
<b class="...blah md blah...">(expression)</b>
<b class="... md ..."></b> not match because tag is empty
<i class="..."></i> not match because class attribute not include md
<span class="...md...">ANYTHING</span> match
<b class="... md ..."> </b>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}