package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(a_msg)\b[^\"]+\"(?<a_msg>[^\"]*)\"`)
var str = `{"log":"a_level=\"INFO\", a_time=\"2021-09-17 07:33:35,210\", a_msg=\"CommissionRouteType: Client / clientId: 111/ planId: 111 / PolicyBusinessId: 111\","level":"info"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}