re = /\b(a_msg)\b[^\"]+\"(?<a_msg>[^\"]*)\"/m
str = '{"log":"a_level=\\"INFO\\", a_time=\\"2021-09-17 07:33:35,210\\", a_msg=\\"CommissionRouteType: Client / clientId: 111/ planId: 111 / PolicyBusinessId: 111\\","level":"info"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end