import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!1?\\d{10}@)[\\w-]+(?:\\.[\\w-]+)*@[\\w-]+(?:\\.[\\w-]+)*\\.[A-Za-z]{2,}$";
final String string = "howard.testman123@gmail.com\n"
+ "1234567890@gmail.com\n"
+ "18005567890@gmail.com\n"
+ "55555555555@gmail.com\n"
+ "321654575321@anything.org";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}