const regex = new RegExp('^(?!1?\\d{10}@)[\\w-]+(?:\\.[\\w-]+)*@[\\w-]+(?:\\.[\\w-]+)*\\.[A-Za-z]{2,}$', 'gm')
const str = `howard.testman123@gmail.com
1234567890@gmail.com
18005567890@gmail.com
55555555555@gmail.com
321654575321@anything.org`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}